• Frame Relay…(In Packet Tracer) *Break Fix*

    Posted on March 12, 2012 by in Tutorials

     

    Whilst I was studying for the CCNA, one of the area I found to be problematic was frame relay within packet tracer. A quick Google search brings up many results with many un-answered threads about how to configure it.

    Seeing as I got it working in the end I thought I would share with you how you go about doing it.

    I’m not going to go in to frame relay and explaining the logic behind it, as if you are looking to configure it then I assume you have some basic knowledge of the topic.

    Firstly, within packet tracer setup 3 new routers and also (go to WAN Emulation) and select Cloud-PT.

    For this demo I’m going to use the following:

    • R1 (which has DLCI 102 (router R1-R2) DLCI 201 (Router R2-R1), DLCI 301 (Router R3-R1), and DLCI 103 (Router R1-R3)
    • R2 (which has DLCI 201 (router R2-R1) and also a DLCI 102 (Router R1-R2)
    • R3 (which has DLCI 301 (router R3-R1) and also a DLCI 103 (Router R1-R3)

    This means R1 will be able to talk to both R2 and R3, but R2 and R3 won’t be able to directly communicate with each other. In order to do this you will need to configure additional DLCI’s, this quick tutorial is just showing you how to get the basics up and running.

    Now we have all this in place, we need to configure the “cloud”, click on the config tab and then click on “serial 1″.

    Within here we need to add the DLCI’s, so for S1 (which will connect to serial 0/0 on R1) type DLCI: 102 Name: R1-R2 and click Add, then do the same for DLCI: 103 Name: R1-R3

    Go to Serial 2 (this will be connected to Serial 0/0/0 on R2) and type: DLCI 201 Name: R2-R1;then

    Go to Serial 3 (this will be connected to Serial 0/0/0 on R3) and type: DLCI 301 Name: R3-R1;finally

    Click on to the Frame Relay tab (under connections) and from the first drop down box, select Serial1, in the second drop down box select R1-R2, in the third box select Serial2 and in the forth box select R2-R1 then click on Add.

    Do the same for the connection to R3 – R1 (as per the screen shot below)

    Now this is done we can start to configure the routers. Start with R1 and run the following:

    Interface serial 0/0/0

    • Interface serial 0/0/0
    • encapsulation frame-relay
    • no shut
    • exit
    This enables Frame-relay on the serial interface. We now need to create the sub interfaces, (again I won’t go in to detail this is purely to get Frame Relay working).
    • interface Serial0/0/0.102 multipoint
    • ip address 81.171.141.1 255.255.255.240 (you can choose any IP address, they must be in the same subnet)
    • frame-relay interface-dlci 102
    • frame-relay interface-dlci 201
    If we flick to Router 2 we now do the same:
    • interface Serial0/0/0
    • encapsulation frame-relay
    • end
    • interface Serial0/0/0.201 multipoint
    • ip address 81.171.141.2 255.255.255.240
    • frame-relay interface-dlci 201
    Now lets get on to Router 3 and configure the below:
    • interface Serial0/0/0
    • encapsulation frame-relay
    • end
    • interface Serial0/0/0.301 multipoint
    • ip address 81.171.141.3 255.255.255.240
    • frame-relay interface-dlci 301
    Now we have configured the routers, we need to make sure we select the correct cable when connecting the router’s to “the cloud”.
    Make sure you select this cable:
    And connect it to the cloud FIRST.
    If we now try to send a packet from R1 to R3 or R2 you should find it is successful
    This gets the routers passing packets to each other. What about if we now stick in a switch off each router and then add some hosts, we we now need to introduce a routing protocol so the routers know what networks are where.
    I would use a simple EIGRP setup like the below: (Router 2 I have two VLAN’s as well as a management interface configured and advertised out so you can ignore those two statements)
    Router 1
    • router eigrp 5
    • network 192.168.1.0 0.0.0.255
    • network 81.171.141.0 0.0.0.15
    • no auto-summary
    Router 2
    • router eigrp 5
    • network 192.168.2.0 0 0.0.0.255
    • network 10.10.10.0 0.0.0.255 (you can ignore)
    • network 1.1.1.1 0.0.0.0 (you can ignore)
    • network 81.171.141.0 0.0.0.15
    • no auto-summary
    Router 3
    • router eigrp 5
    • network 192.168.3.0 0 0.0.0.255
    • network 81.171.141.0 0.0.0.15
    • no auto-summary
    You should find that as you are going along entering these commands you see the neighboring adjacency’s form, and once you start adding hosts you should be able to ping across from one network 192.168.1.0/24 to a host on 192.168.3.0/24.
    The Break fix lab I have included in this is shown below: (Now I will admit, when I was building this I did configure R3 as R2 and R2 as R3, and I simply went in and then updated the hostname’s on both routers), which means you will have to use show run and not just rely on the notes I have on screen. (which is what you would do in the real world anyway right!? :p )

    I have broken quite a few things in this lab, I won’t say what but as always have included the answers in the break fix lab fix (you just need to scroll to the bottom right to find the answers).
    Every host should be able to ping every host in both it’s own network and also the other two networks. (i’ve configured fram relay so all 3 routers can talk to each other so R1-R2, R1-R3, R2-R1, R2-R3, R3-R1, R3-R2)

     

    Enable password = michael

     

    Good luck

     

     

13 Responses so far.

  1. Patricia says:

    cool!

  2. website says:

    Have you considered adding some social bookmarking buttons to these blogs. At least for flickr.

    • Michael says:

      I’ve included sharenow button’s for Facebook / Linkedin / Twitter and google.

      I had not considered Flickr, but will look in to it

  3. Jules Shevenell says:

    I just want to say I am beginner and certainly liked this page. Many thanks for sharing.

  4. Jeremy brown says:

    Very interesting. Thank you, Take care. Jeremy

  5. Willy Kuroda says:

    I want to mention I’m very new to blogging and actually savoured this blog site. Thanks a lot for sharing

  6. Bruna Treml says:

    Works very well thank you

  7. timisoara says:

    Pleasant page, I genuinely enjoyed studying it, keep up the hard work.

  8. bessere welt says:

    I saw a lot of website but I conceive this one has something extra in it in it

  9. I simply want to tell you that I am just beginner to weblog and definitely enjoyed you’re web site. Likely I’m planning to bookmark your blog . You amazingly have very good articles and reviews. With thanks for sharing with us your website.

  10. Elora says:

    Impressive brain power at work! Great anwser!

  11. Logan Reising says:

    I just want to mention I am new to blogs and truly savored this blog. You surely have amazing well written articles

  12. Garrett says:

    Great post, really enjoyed it!
    — Garrett


Protected by WP Anti Spam